Billing Time Rounding Always Up seems not working

Hello, i’ve set billing rounding for disconnection time to be always up, it should do a rounding based on milliseconds but it seems not working. What I see on db for billed calls is not a rounded closing time, like this:
time_connect: 2022-06-02 21:11:05.157665+02
time_end 2022-06-02 21:11:32.066346+02
but I was expecting it would be 2022-06-02 21:11:33.000000+02
duration: 27 seconds, again I was expecting 28
Please let me know.
Thanks a lot

There is no disconnect time rounding. We are rounding call duration: 32.066−5.157 = 26.909. then 26.909 rounded up according to your settings. Result is 27. Configuration variable also called CALL DURATION ROUND MODE

Yes, that absolutely make sense. I confused call duration and time end. But most terminations are making rounding based also on time end, I think you should implement also this functionality.
Thanks a lot

What I would like to see is rounding up based on:
time_connect and/or time_end milliseconds time

and on reports I’d like to see duration distinct on 2 fields, one for customer call duration and the second as billed duration.