Debugging Dialpeer selection


#1

Is there way to debug dialpeer selection and why it could not selected? As call is not routed with disconnect code 0.404 - No routes

  • 8.871 ms -> DST. search start. Routing key: 671888555. Routing tag: {1}
  • 10.154 ms -> DST. found: {“id”:4201532, “enabled”:true, “prefix”:"", “rateplan_id”:14, “next_rate”:5.0, “connect_fee”:0.0, “initial_interval”:1, “next_interval”:1, “dp_margin_fixed”:0, “dp_margin_percent”:0, “rate_policy_id”:1, “initial_rate”:10.0, “reject_calls”:false, “use_dp_intervals”:false, “valid_from”:“2019-01-22T09:00:00+02:00”, “valid_till”:“2024-01-22T09:00:00+02:00”, “profit_control_mode_id”:null, “network_prefix_id”:null, “external_id”:null, “asr_limit”:0, “acd_limit”:0, “short_calls_limit”:0, “quality_alarm”:false, “uuid”:“798542ac-1e13-11e9-a146-525400cbd819”, “dst_number_min_length”:0, “dst_number_max_length”:100, “reverse_billing”:false, “routing_tag_ids”:[1], “routing_tag_mode_id”:0}
  • 10.721 ms -> DP. search start. Routing key: 671888555. Rate limit: Infinity. Routing tag: {1}
  • 13.753 ms -> Dialpeer search done
  • 14.173 ms -> DONE.

#2

Looks like you don’t have dialpeer for number 671888555 and with routing tag = 1
Try to filter dialpeers using ROUTING FOR CONTAINS=671888555 filter on Routing->Dialpeers page. Such filter will show dialpeers that could be used for your call.


#3

Should work then, bot not working =(

Seems like been problem in showing the enable status in browser. Now started to works, when I enable/disable it again.


#5

May be you created it with enabled=No ?


#6

@Xen0x try to find how Dialpeer was created. In Logs->Audit log you can found create event for this dialpeer and check initial parameters. I think it was created with enabled=false.


#8

The problem was with different Route Plan and Route Group for Customer Auth. Sorry new to this product.