SEMS node installation incorrect password

Hi guys,

I am setting up an environment with yeti but ran into an issue with starting the SEMS node.

When using ‘sems -E -D3’ I get the following result;
[3374/3402] [apps/sctp_bus/SctpClientConnection.cpp:180] INFO: SCTP_ASSOC_CHANGE: 13. remote: 127.0.0.1:4444
[3374/3402] [apps/sctp_bus/SctpBus.cpp:321] DEBUG: process sctp send raw event request yeti -> 0:mgmt
[3374/3402] [apps/sctp_bus/SctpClientConnection.cpp:268] DEBUG: SEND sctp_bus event request 9:yeti/13 -> 0:mgmt seq: 1
[3374/3404] [core/AmThread.cpp:85] INFO: Thread 140668000417536 is starting.
[3374/3374] [yeti:cdr/TrustedHeaders.cpp:47] ERROR: pqxx_exception: FATAL: password authentication failed for user “yeti”
FATAL: password authentication failed for user “yeti”

[3374/3374] [yeti:cdr/TrustedHeaders.cpp:60] ERROR: can’t load trusted headers config

I’m not really sure where I should update the password.
I tried updating the CDR user password in /etc/yeti/system.cfg, unfortunately to no avail.

Can somebody point me in the correct direction? :slight_smile:

Nevermind, I had a typo in the password of the master and slave pool. :sleepy:

I’m continueing with the next error. :wink:
[2005/2005] [yeti:yeti.cpp:132] ERROR: timeout waiting yeti config via SCTP
[2005/2005] [yeti:SBC.cpp:148] ERROR: yeti configuration error

Update for others; it seemed that the schemas were incorrect.
I also had to enable serialize_dynamic_fields.

looks like your yeti-management daemon is not running

Could you just install system as described in manual https://yeti-switch.org/docs/en/installation/index.html# ? You should not use default configuration files because they are not related to yeti. Only documentation contains valid configuration examples.

https://github.com/yeti-switch/sems/issues/4 also caused by using default config files instead of using examples from manual.