Upgrade 1.12.113-1 to 1.12 1.12.140-1 or higher version

Hi Team,

How can I manually update to a higher revision?
I have tried it in the laboratory but as the same website indicates, the complete procedure is not there.


systemctl stop yeti-web.service 
systemctl stop yeti-cdr-billing@cdr_stats.service 
systemctl stop yeti-cdr-billing@cdr_billing.service 
systemctl stop yeti-delayed-job.service 

cp /opt/yeti-web/config/secrets.yml /root/secrets.yml
apt update && apt install -y yeti-web=1.12.140-1 

# Ensure the secret  /opt/yeti-web/config/secrets.yml file exist.

cd /opt/yeti-web || exit
su -s /bin/bash yeti-web

# To upgrade databases to the latest version:
RAILS_ENV=production ./bin/bundle.sh exec rake db:migrate


Could you add details what exactly you tried and what problem you faced.

Thank you so much.

The process failed since it did not stop the services before starting the upgrade.
For some reason when the services are active prior to the upgrade, it does not end well and breaks the database structure.

It doesn’t look as valid explanation - active service can’t cause issues with database.

Anyway it is not possible to say exactly - you are not providing any issue details like error messages, or logs.

I probably expressed myself wrong.
I don’t know if it breaks the database but it does break some part of the web application.
The only difference from how I was doing it and it failed versus how I did it and it worked, was with Max recommendation.
Stop services first before upgrading