Visible Table Columns in CDR History

Hello all,
I am trying to restrict the visible columns in CDR History page order to reduce the exported file. I click on “Visible Columns” link and choose 6 or 7 column name, then press the “Show” button and nothing happens. It says loading… and that is all. Am I doing something wrong?

Thank you in advance.

  • We need server side logs to answer
  • Reducing visible columns will not affect logic of CSV Download

CSV Download on CDR History page is not designed for big amounts of data. Use CDR->CDR exports tool to export CDRs, it allows to define columns and has much better performance.

Hello dmitry, thank you for your reply. I will try CDR exports and let you know. Thank you!

Hello Dmtry, We tried to use CDR-> cdr exports and had the following result:

This site can’t be reached

The webpage at might be temporarily down or it may have moved permanently to a new web address.


We configured /etc/nginx/sites-enabled/yeti-web as described in the instructions (BTW we are using version 1.11).
We also found a post from july 2020 where someone had the same issue and you replied that this was a bug and was going to be solved in a few days…maybe this issue is still open?

Thank you!!

Hello Dmtry, I think we found the problem. This is because when the file is created (in our case in /tmp) by postgres, it is created with no rights to other users/groups…like this:
-rw------- 1 postgres postgres 7716597 Aug 5 15:49 1.csv.gz

When you try to download it, you can not.

If you change the file’s rights to -rw-r–r-- then you are able to get it.

Thank you!

you could try to change directory default permissions

Thank you dmitry!
directory’s permissions for /tmp are 777 (rwxrwxrwx) already, but the cdr exported file is created like -rw------- by postgres user… I do not know how to change that…


read about getfacl/setfacl