Yeti Client Setup

Hi there,

I have installed yeti client using the following repo.

deb http://pkg.yeti-switch.org/debian/stretch nightly main

Here is the config for /opt/yeti-client/dist/config.js

// eslint-disable-next-line
CONFIG = {
  yeti: {
    apiBaseUrl: 'https://client1.domainname.com',
    blockedPages: new Set([]),
  },
};

// Possible values for yeti.blockedpages set are 'rates', 'accounts', 'cdrs'

All the required applications such as pgqd, nginx, yeti-web, kamailio, yeti-lb, etc running on the same server. My question is where can I define/set customer portal domain in the system.

I tried to use https://client1.exampledomain.com but it ends with Admin panel page.

Sorry If I have not explained this correctly. Thanks in advance.

Regards
Armaan

You have to configure nginx to serve yeti-client files.
configuration example:

server {
        listen 80;
        server_name client.demo.yeti-switch.org;
        root /opt/yeti-client/dist;
        access_log /var/log/nginx/yeti-client.access.log;
       
        location / {
                rewrite ^/(.*) https://client.demo.yeti-switch.org permanent;
        }
}

server {
        listen 443;
        server_name client.demo.yeti-switch.org;

        ssl on;
        ssl_certificate /etc/letsencrypt/live/client.demo.yeti-switch.org/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/live/client.demo.yeti-switch.org/privkey.pem;

        ssl_session_timeout 50m;
        ssl_session_cache builtin:1000;
        ssl_protocols TLSv1.2;
        ssl_ciphers  ECDHE-RSA-AES256-SHA384:AES256-SHA256:RC4:HIGH:!MD5:!aNULL:!eNULL:!NULL:!DH:!EDH:!AESGCM;
        add_header Strict-Transport-Security "max-age=31536000; includeSubdomains";
        ssl_prefer_server_ciphers on;

        access_log /var/log/nginx/yeti-client.access.log;

        root /opt/yeti-client/dist;

        index index.html;
        
        location / {
        }
}

thanks Dmitry for your quick reply :slight_smile:
Does the above config has to go under /opt/yeti-web/config/yeti-web.dist.nginx ?
If so here is the file: https://pastebin.com/4cQa772v
Tried to use the above config, restarted nginx & yeti-web & still can’t access client portal :frowning:

thanks in advance.

It was just example

ssl_certificate /etc/letsencrypt/live/client.demo.yeti-switch.org/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/client.demo.yeti-switch.org/privkey.pem;

will not work for you.

Check logs for errors, because still can’t access client portal contains zero information

HI Dmitry,

Hope you are doing good, I configured my Nginx and Yeti, the client web page pops up now but the login button does not work ? i checked the logs but nothing on the logs. Any idea ?
I also allowed my server IP below API access in yeti nginx file but no luck.
server {
listen 127.0.0.1:6666;

Check browser debug tools for error

1 Like

getting the below error

Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.