Yeti's Caller ID

I am unable to set caller-id in yeti. What I am doing is placing caller-id number in “vendor src rewrite rule” in gateway translations menu. But traffic capture shows “from header” set to username of sip trunk provided by vendor. Vendor’s webportal also shows call ANI set to username provided by vendor. Every call is failing with error code 500. I assume call failure with code 500 is due to improper caller-id. Is there something wrong that I am doing?

Yes. auth_from_user has been set at termination gateway.

could you choose right category for each topic? This case is not related to Yeti installation and upgrade

Error 500 removed. But call still not proceeding. Getting codes 482 &407 (loop, proxy auth).
1 thing I would like to mention is, vendor requires registration as well as user/pass authentication. That’s why I checked “Auth Enabled” in signaling->termination menu. Hope it might help.

Sure, moved to Yeti-Switch.

Ok, 1 more update. I mistook

with “Auth Enabled”. Cleared the “Auth From User” field. Now 500 is back.

Yeti seems to be sending Cancel message after session progress message.
On Vendor server CDR shows Termination Code 487.

could you share a pcap trace?

Issue has been resolved. Deeper look revealed that there was a codec mismatch. That’s why yeti was sending CANCEL messages after 100 TRYING was received. This time RTP traffic isn’t working fine. Working on that, if issue I would create a new topic. Thanks a lot.